PHP 7.2 compatability

Home Forums Support Forum PHP 7.2 compatability

Tagged: 

This topic contains 1 reply, has 2 voices, and was last updated by  Anti-Malware Admin 1 year, 4 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #2240

    Hi,

    I need to upgrade my database to PHP 7.2 and wondered if your plugin was compatible? When I ran a compatibility test I got this message: wp-content/plugins/gotmls/safe-load/wp-settings.php

    ———————————————————————————————————————–

    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE

    ———————————————————————————————————————–

    35 | WARNING | INI directive ‘mbstring.func_overload’ is deprecated since PHP 7.2

    ———————————————————————————————————————–

    #2241

    Anti-Malware Admin
    Key Master

    Yes, My plugin is completely compatible with PHP 7.2 and this deprecated directive WARNING about “mbstring.func_overload” is irrelevant for a number of reasons.

    First, the code in that plugins/gotmls/safe-load/wp-settings.php file is copied exactly from the WordPress core files as an emergency backup feature. So it is not only rarely ever used but it is also present in the WP Core files.

    Second, the code in question is only testing to see if this deprecated directive “mbstring.func_overload” is being used, not actually even trying to use it. So it would not cause and error but rather it would detect if the directive was set, which it should not be.

    Third, even if a deprecated directive were to be used in some other code on your site it should not cause any errors on a production server because DEPRECATED warnings should be suppressed in your php.ini file anyway.

    I have to add that this plugin you used to check for compatibility issue can’t be very good if it does not pick up on or address these three very important points.

    Please let me know if you have any further questions.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Comments are closed.