cannot update the definitions

Home Forums Support Forum cannot update the definitions

This topic contains 13 replies, has 5 voices, and was last updated by  Bernardo Cienfuegos 11 years, 9 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
  • #203

    Larry Wilcox

    I just registered the product but when I try to update the definitions I just get taken to a not found page on the site.


    Anti-Malware Admin
    Key Master

    I have released a plugin update that may fix this issue for you. There are also new definition updates that find new variants of these malicious scripts.

    Please upgrade to the newest version of my plugin and try to update the definitions. And please let me know if it is working for you now.

    Aloha, Eli


    John Doe

    I also am unable to update the definitions file. When attempting to, it shows a page that says:

    Method Not Implemented

    POST to /wp-admin/admin.php not supported.


    Anti-Malware Admin
    Key Master

    “Method Not Implemented” for POST sounds like a problem on your server. Is there any form on your site that does work?

    Can you give me access to your site to check it out?


    Will revive this post, as its also related.
    I did install the plugin, took the opportunity to make a small donation based on the contents of this site and then clicked “Update definitions”. After that I got to an error page: “Forbidden You don’t have permission to access /wp-admin/admin.php on this server.”
    Any ideas about what I could do?


    Eli Scheetz

    Thanks for posting. This type of error, while different from the other, is still eluding me. None of the prior posters responded to my replies or requests. If you are willing to work with me on this issue I would very much like to troubleshoot and solve this on your system.

    Please reply directly to this notice if you are willing to help me investigate this problem further.


    Login information sended. Good luck!


    Eli Scheetz

    Thanks. I got in. I see that the problem on your site extends beyond my plugin. Not only does it prevent my plugin from posting a large amount of data to update the definitions but it also prevents me from using the built in plugin-editor to update my plugin when I tried to modify my plugin to work around this issue. As a test, I also tried to create a test page with a lot of content and save it as a draft but it too failed. Your server appears to break when receiving a large amount of POST data. Has it always been like that or do you think it is a result of getting hacked?


    Thanks for the fast reply. I did change to this server last week. They have a terrible service, with a bad support as well. The sales department did a very nice job selling it to me. I am sorry that the 30 day money back guarantee was a lie too: “only for specific technical problems”….
    Sometimes I can’t even upgrade a WordPress installation or theme..
    Anyways, you may have your answer now: it does not work with low resources servers… still, nice to be able to contribute. Anything else I could try?
    Can I maybe download the definitions myself and try to use it after that?


    Eli Scheetz

    We have an answer but I’m not satisfied. I want my plugin to work, even on low resource servers. Plus, I’m not convinced that there is not still another reason you cannot post forms in your admin.

    I would like to keep trying until I find a way to get it to work on your server if that is ok with you.


    Feel free to continue to experiment. Just please do not forget to delete possible code that could be detected as malware in a server scan (it can suspend my account) and please keep the blog information as it is.


    As I see that I can perform a scan without the database, and the problems appears to be with the upgrade, is there any way I could update the database by hand to be able to use it?


    Eli Scheetz

    I just release an update that fixes this issue. I upgraded my plugin on your site to the new version and was then able to update the definitions. I also ran a scan on your site and no threats were found :-)


    Great! Thank you very much and I am sure I will not be the only one happy about this :)
    Keep up the good work!

Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘cannot update the definitions’ is closed to new replies.

Comments are closed.