Revert did not work after failed quarantine

Home Forums Support Forum Revert did not work after failed quarantine

This topic contains 3 replies, has 2 voices, and was last updated by  Paul Wayne 5 months, 2 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1905

    Paul Wayne
    Member

    Hello – This post is meant to be informative to the developers concerning a failed revert.

    After running a scan, malware was found in all the theme functions.php files.

    I clicked on ‘clean’.  The automatic site test stayed red, indicated the clean did not work.  I clicked on ‘revert’, but the site remained broken.

    The malware was on line 1 of the functions.php file. The error after cleaning was:

    Parse error: syntax error, unexpected ‘)’ in /home/content/p/r/o/prongpower/html/wp-content/themes/twentyfifteen/functions.php on line 1

    Malware was still in the file, with a leading ‘)’ causing the error.

    I resolved by restoring a clean file from backup.

    malware infected file available by request if it helps your troubleshooting.

    #1906

    Anti-Malware Admin
    Key Master

    Thanks for reporting this issue. Please send me one of the infected files so that I can see why it failed to clean it and fix this issue.

    #1907

    Anti-Malware Admin
    Key Master

    Thanks for sending me that whole file. I have updated the definitions so that threat will be correctly and completely removed in future scans.

    I am also working on fixing that bug that caused the revert link to fail for you…

    #1908

    Paul Wayne
    Member

    Thank you for your super fast response and the continuous software improvements !

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Comments are closed.